Email Delivery Backlog
Incident Report for Dot Events
Resolved
The email backlog has now been cleared. The email service should be working normally
Posted Aug 13, 2020 - 11:02 BST
Identified
We have identified an issue causing emails to be delayed, this is due to as large amount of emails in the outbox. The emails are being sent slowly. We will update this once all the emails have been sent.
Posted Aug 13, 2020 - 10:55 BST
This incident affected: Email Hosting.